2 Replies Latest reply: Sep 20, 2018 12:17 AM by Thi Pham RSS

    How to send selection via URL

    Thi Pham

      Hello guys,

       

      Before Qliksense version Jun 2018, I followed the instruction here: https://help.qlik.com/en-US/sense-developer/2.1/Subsystems/Dev-Hub/Content/Howtos/single-configurator-include-single-selection.htm?_ga=2.152039801.1990527839.1537413595-882982839.1530790590

      to redirect page to new dashboard with selection (with structure like: http://url ... select=Dimension,Selection) from current dashboard (in url representation of table).

      However, after that version, Qliksense got a change which parse special characters in url to html encode, then the string is parsed to something like http://url ... select=Dimension%2CSelection) , and the link doesn't work anymore.

      I submitted a ticket to Qlik Force already and they recorded it's a bug, however after 2 months, they said it's a limitation because they have no solution right now.

      This kind function is very useful with me to separate dashboards and till satisfy users because they can quickly and easily go through of their data story. Anyone had a workaround for this?

       

      Thanks,

      Thi.

        • Re: How to send selection via URL
          Rahul Thakkar

          Hi,

           

          I was recently looking for something similar and got to know about this extension -

           

          https://developer.qlik.com/garden/57904554c6d9b3f56ce04987

           

          I am yet to fully test this one in my environment but you can give it a try and let me know your experience as well.

           

           

          Regards,

          Rahul

            • Re: How to send selection via URL
              Thi Pham

              Hello,

               

              Thanks for your reply!

              However, it is not a solution for my case.

              Just imagine, I create a table, at a dimension, I use URL representation with the single configuration and the urls are generated dynamically for each value of dimension (like 1st row: http://url ... select=Dimension,A, 2nd row: http://url ... select=Dimension,B ....)

              when clik to the table at that dimension, I expect it redirectly to new app with selection defined in the URL.

              I worked perfectly in qliksense version older than June 2018.

              In new version, the link are parsed to  select=Dimension%2CA when the table is loaded -> not work anymore.

              If I edit the url on browser manually (%2C -> ,),then I still work, but it couldnt be a good workaround.

              I tried to generate the url respectively to value of dimension in data load -> still got same issue.


              Thi.