8 Replies Latest reply: Oct 23, 2018 2:36 PM by Giles Walker RSS

    Perceived Issues/bugs related to Qlik Sense Jun-18 release

    Giles Walker

      I am a Qlik Sense administrator and developer.  I consider myself an experienced user.  I recently migrated to Qlik Sense Jun-18. I wanted to share a few things I have experienced and which I think ‘might’ be issues in this version.  These are things I have experienced in this new version, that I have never experienced in any prior versions.  Please note that 2 of my issues are related to the ‘relationship’ between the Jun-18 version of Sense and the Jun-17 release of nPrinting (17.4.0).  Note I am planning to upgrade nPrinting to the Jun-18 release in the coming weeks.

       

      Disappearing Customization

       

      I recently worked on a new app, customizing the load script and adding calculated dimensions and measures inside the app. I published the app, and it published ok according to the on screen confirmation.

       

      On immediately opening the app, all the customization had been removed from the load script, dimensions and measures.  I was left with a virgin load script, and mere ‘vapour trails’ inside the app.

       

      pic1.jpg

       

      On checking the QMC it showed the app with a blank migration status.  This is really unusual as normally it says “successful”.  This has never happened before.

       

      pic2.jpg

       

      nPrinting Connection refresh fail

       

      I have had a connection in nPrinting to an existing application in Sense for a long time.  On 17th August (well after migration to Jun-18 version of Sense) I successfully refreshed the connection to pull in some amended data calculations.  On 31st August I needed to refresh the connection after adding a new chart to the app in Sense, but the connection wouldn’t refresh.  Error was “Sequence Contains No Elements”.

       

      pic3.jpg

       

      So I backed out my small change, re-ran the connection refresh and got the same error.  There had been no other changes made to the app (I know this as I am the administrator) that could be associated to this.  I tried restarting both the Qlik Sense and nPrinting servers we operate on, but the error continued.

       

      This situation harvests no useful error messages in nPrinting unlike other nPrinting errors (although their level of usefulness is questionable as you need a PHD to understand them).  I didn’t resolve this issue immediately and I had tried today and got this error – this is all I have to work on which is really not helpful.

       

      pic4.jpg

       

      I tried a few other things to resolve, but nothing worked until I decided to clone the original app and delete some of the sheets to see if size was an issue.  The app has a lot of sheets, so I deleted 50% of them, then the refresh worked.  I then cloned the original again, and deleted 10% and it worked.  I did it again with just a couple of sheets and it failed again.  So I repeated the 10% example again (it worked) and then I just started cloning sheets inside the app to get back to a level where the qty of sheets was back to the original and it still worked. 

       

      Deduction therefore would point to the fact that one of the deleted sheets was causing the issue, but the problem I have with that, is that in the original app, no changes were made to it after the last successful refresh on 17th August (other than the new sheet I added and then deleted) and thus the status quo should have remained, ie it should have worked as by definition, nothing was different.

       

       

      First time nPrinting has produced corrupted output

       

      Out of nowhere, nPrinting started pushing out reports with garbage data.  I have never seen this before.  What is more, the results of each subsequent data production also produced garbage, but each iteration was different garbage.

       

      A small example is below in the image. 

       

      I knew what Sense was producing, thus what nPrinting should have been replicating as output.

       

      pic5.jpg

       

      As you can see hopefully from the image narrative, it wasn’t until Qlik Sense server was rebooted that the data was produced correctly. Ordinarily I would have expected with any issue like this that Sense had hung or crashed or something else obvious, but in this instance Sense (by itself) was operating perfectly normally.  The applications were available, the QMC was running updates with no issue etc.  I have been trying to reproduce this issue, and almost 3 weeks later, I have had no luck.

       

      In closing, again I'd like to express that these are observations I have had.  In the main I have not been changing anything or doing anything out of the ordinary - I am an experienced user and I know how to operate the tools.  Things have been behaving out of character and I don't consider any actions I have performed have led to these outcomes.

        • Re: Perceived Issues/bugs related to Qlik Sense Jun-18 release
          Giles Walker

          Additionally I have experienced 2 more situations where duplication of apps (whether in Sense or QMC) results in a missing migration status, which is unusual.  The apps this time appear to have all their script developments and measures etc, however I don't think this is normal behaviour.

           

          missing migration status 1.jpgmissing migration status 2.jpg

          • Re: Perceived Issues/bugs related to Qlik Sense Jun-18 release
            Giles Walker

            Next 'bug' - In Qlik versions prior to Jun-18 release, I was able to happily edit live published apps that were on a frequent refresh interval - like 5 mins.  I could be editing in the live version and if a data update happened during that edit (driven by QMC), the app would maintain it's integrity. 

             

            In Jun-18 version, when doing the same thing, I am seeing spurious results retrieved.  I am getting some incorrect outcomes presented by Qlik in calculated fields.  Also if data is filtered when in edit mode in Sense, and a refresh runs in the background, the application of filters also changes.

             

            If I exit edit mode, and run a manual refresh, or wait for the QMC to refresh for me, the results correct themselves.

             

            Example of an incorrect outcome, spurious entries highlighted in green:

            LAMS fail 1.jpg

             

            I left the app to then refresh itself, and the figures correct automatically:

             

            LAMS fail 2.jpg

            • Re: Perceived Issues/bugs related to Qlik Sense Jun-18 release
              Giles Walker

              Next 'bug' - this morning, some filters in one of the Sense apps failed to produce the correct results.  A user had me update a LOAD script to fix some missing data, and when tested, Sense was then displaying the correct results.

               

              After 5-10 minutes, the user accessed the published app on their terminal and with the desired filters applied, Sense didn't filter the data correctly.  Selecting a single field value resulted in 2 values being displayed on the screen, not 1.  On checking on my terminal the same was true.  The additional field could not be gotten rid of by any means of selecting available in Sense.

               

              So I reloaded the data, which seemed to clear the issue, but after 5 mins the user tried filtering on a single week number, and it gave him 2 weeks of data, neither week number being the week number he had chosen.

               

              Server was then rebooted, and the issue went away with no other intervention.

              • Re: Perceived Issues/bugs related to Qlik Sense Jun-18 release
                Giles Walker

                Another bug not present in previous versions of Qlik Sense...

                 

                If you are in an open expression editor, and then you go to the Data Load Editor and run a refresh (ie press "load data" button), the open expression editor becomes 'frozen' in that you can't navigate anywhere, or save any further changes to the script inside the editor.  Per the picture below, the functional menus and buttons get greyed out.  You have to refresh the browser to be able to do anything further.  (Note: You can still edit the scripts in the editor, but this is pointless as you cannot save changes).

                 

                expression editor bug.jpg

                • Re: Perceived Issues/bugs related to Qlik Sense Jun-18 release
                  Giles Walker

                  Next bug found.

                   

                   

                  I have an unpublished app open (ie it's in my work stream), and I need to data refresh.  Go to DataLoad Editor, and load data....no issues with the data load.  When I go back to the open Google Chrome tab, the app is telling me that of course a reload is in progress.  However it's now started to not remove the warning box by clicking 'Close' once.  The one experienced in the app I am working in takes 5 goes to remove the warning, and the screen gets lighter each time you press 'Close' - see picture below.  Quite comical actually, if a bit annoying.  Some apps just require 1 click of close.  Another app needs 8 attempts to remove the warning.

                  shades.jpg

                  • Re: Perceived Issues/bugs related to Qlik Sense Jun-18 release
                    Giles Walker

                    Last night we upgraded to Qlik Sense Sept 2018 Patch 1 (qliksenseserver:12.36.3) and the same issue regarding corrupted nPrinting output was present upon restart.  Using prior experience, after assessing bad output, I restarted the server Qlik is on, restarted all the services, and re-ran my nPrinting output.  The corrupted output was removed, leaving data that is good.